CentOS Linux更新内核dracut-kernel问题处理

欢迎您,来自IP地址为:54.81.59.211的隐士朋友

付款前,可以输入宝贝名称查一查有没有优惠券可以用哦!


本服务器采用CentOS 6.x发行版,并自己更换为elrepo的内核,以保持内核为最新版本。近期将内核更新至4.12.10-1版本时,遇到系统报错,提示:

error: Failed dependencies:
dracut-kernel >= 002-18.git413bcf78 is needed by kernel-ml-4.12.10-1.el6.elrepo.x86_64

分析原因,是由于4.12.10内核需要dracut-kernel工具,系统未安装而造成更新不成功。

解决办法也很容易,yum install dracut-kernel命令安装上即可。

发表评论

电子邮件地址不会被公开。 必填项已用*标注